摘要:基于 SSH 的文件传输协议 SCP(Secure Copy Protocol)被曝存在安全漏洞。安全研究人员公布了 SCP 存在的多个漏洞,这些漏洞可以结合起来利用,分别为 CVE-2018-20685、CVE-2019-6111、CVE-2019-6109 与 CVE-2019-6110。

知名文件传输协议SCP被曝存在35年历史的安全漏洞-黑产爆破吧

基于 SSH 的文件传输协议 SCP(Secure Copy Protocol)被曝存在安全漏洞。安全研究人员公布了 SCP 存在的多个漏洞,这些漏洞可以结合起来利用,分别为 CVE-2018-20685、CVE-2019-6111、CVE-2019-6109 与 CVE-2019-6110。

  漏洞中最主要的地方是 SCP 客户端无法验证 SCP 服务器返回的对象是否与请求的东西一致,而该问题可以追溯到 SCP 的基础——RCP 协议(Remote file Copy Protocol),它允许服务器控制发送的文件,那么结合客户端无法验证请求与实际返回的对象是否一致这一弱点,攻击者就可以采用中间人或直接操纵 SCP 服务器的方法,覆写客户端用户的 .bash_aliases 文件,一旦用户启用 Shell,则执行文件中的恶意代码。

该问题从 1983 年起已经存在了 35 年。受影响的客户端包括 OpenSSH scp、PuTTY PSCP 与 WinSCP scp mode。

OpenSSH scp        <=7.9    
PuTTY PSCP         ?       
WinSCP scp mode    <=5.13

安全人员表示可以采取以下措施解决/缓解该问题:

  • 如果可以,就把 OpenSSH 切换到 sftp 协议,不然就下载补丁强化 SCP:https://sintonen.fi/advisories/scp-name-validator.patch
  • WinSCP 更新到 5.14 以上版本,目前问题已经解决。
  • PuTTY 现在还没有可选方案。

详情查看安全公告:https://sintonen.fi/advisories/scp-client-multiple-vulnerabilities.txt